stylix/modules/console/nixos.nix
2024-12-24 16:04:27 +01:00

28 lines
455 B
Nix

{ config, lib, ... }:
with config.lib.stylix.colors;
{
options.stylix.targets.console.enable =
config.lib.stylix.mkEnableTarget "the Linux kernel console" true;
config.console.colors = lib.mkIf (config.stylix.enable && config.stylix.targets.console.enable) [
base00-hex
red
green
yellow
blue
magenta
cyan
base05-hex
base03-hex
red
green
yellow
blue
magenta
cyan
base06-hex
];
}