11 lines
263 B
Nix
11 lines
263 B
Nix
{ config, lib, ... }:
|
|
|
|
{
|
|
options.stylix.targets.fish.enable =
|
|
config.lib.stylix.mkEnableTarget "Fish" true;
|
|
|
|
config = lib.mkIf (config.stylix.enable && config.stylix.targets.fish.enable) {
|
|
programs.fish.promptInit = import ./prompt.nix config;
|
|
};
|
|
}
|