15 lines
394 B
Nix
15 lines
394 B
Nix
{ config, lib, ... }:
|
|
let
|
|
themeFile = config.lib.stylix.colors {
|
|
template = ./template.mustache;
|
|
extension = ".css";
|
|
};
|
|
in
|
|
{
|
|
options.stylix.targets.vesktop.enable = config.lib.stylix.mkEnableTarget "Vesktop" true;
|
|
|
|
config = lib.mkIf (config.stylix.enable && config.stylix.targets.vesktop.enable) {
|
|
xdg.configFile."vesktop/themes/stylix.theme.css".source = themeFile;
|
|
};
|
|
}
|