50 lines
615 B
Bash
50 lines
615 B
Bash
# Maintainer: OnTake <ontake@ontake.dev>
|
|
pkgname=ontake-base
|
|
pkgver=1
|
|
pkgrel=1
|
|
pkgdesc="Base system configuration"
|
|
arch=('any')
|
|
url="https://git.ontake.dev/sys/arch"
|
|
license=('MIT')
|
|
provides=(
|
|
'vim'
|
|
'vi'
|
|
)
|
|
conflicts=(
|
|
'vim'
|
|
'vi'
|
|
)
|
|
depends=(
|
|
'base'
|
|
'btop'
|
|
'cpupower'
|
|
'curl'
|
|
'exa'
|
|
'fastfetch'
|
|
'fd'
|
|
'fish'
|
|
'git'
|
|
'less'
|
|
'lsof'
|
|
'neovim'
|
|
'openssh'
|
|
'pacman-contrib'
|
|
'ripgrep'
|
|
'rsync'
|
|
'sudo'
|
|
'tldr'
|
|
'tmux'
|
|
'tree'
|
|
'ufw'
|
|
'which'
|
|
)
|
|
source=(
|
|
'fishbinsh.hook'
|
|
)
|
|
md5sums=(
|
|
'ed23a29fab3d5bf38f5a7ac68259cceb'
|
|
)
|
|
|
|
package() {
|
|
install -Dm 0644 fishbinsh.hook "$pkgdir/etc/pacman.d/hooks/fishbinsh.hook"
|
|
} |